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SCORGTM Setup for CFD Simulation of 

Twin Screw Machines with Simerics Inc. 

Simerics-MP+® Solver 
 

SCORGTM is the CFD grid generation tool for rotary twin screw machines. The tool includes 

additional modules for designing and editing rotor profiles, executing a thermodynamic 

calculation based on quasi 1D chamber models and generating the deforming working chamber 

grids for selected commercial CFD solvers. For more information on the product please visit 

the website: www.pdmanalysis.co.uk or refer to documentation help. 

This guide lists the steps for setting up a CFD simulation for Twin Screw Compressor with 

SCORGTM and Simerics MP+ Solver. The user is expected to be familiar with screw machines, 

CFD and Simerics MP+ in order to be able to use these procedures. It is highly recommended 

that books on that topic are studied12 

Refer SCORGTM Installation Guide for system and hardware requirements. 
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1 Introduction 

Screw Compressors are rotary positive displacement machines. Although the working principle 

of these machines is simple, the geometry of rotors which are in the form of multi -lobe helical 

screws meshing with each other, is making analysis by use of Computational Fluid Dynamics 

(CFD) challenging. The process starts when the lobes are engaged at one end, which creates 

continuous increase of the volume between the rotors and the casing which reduces pressure in 

the suction domain and draws the working fluid in. Further rotation of the rotors makes this 

volume between the rotors and the casing enclosed when the compression of fluid begins. This 

increases the pressure within the chamber. Further rotation exposes the pressurized fluid to the 

outlet port and the fluid is delivered (Stosic, et al., 2005). Similar process is occurring in other 

helical screw machines such as pumps, vacuum pumps, gear pumps, expanders, extruders and 

motors. The CFD is equally challenging in such machines due to sliding and stretching  

The main objectives of CFD simulations of a screw compressor are to: 

a. Obtain the pressure field inside the rotor chamber and in the suction and discharge 

domains. Example shown in Figure 1-1. 

b. Obtain the velocity fields in critical regions of the computational domain. 

c. Obtain temperature fields in critical regions of the computational domain. 

d. Obtain integral parameters of the machine such as power, mass flow rate, discharge 

temperature, torques on the rotor shafts, etc. 

e. Obtain the loads and temperatures on boundaries with solid parts of the machine for 

further structural and thermal analysis. 

 
Figure 1-1 Pressure Variation diagram of a Twin Screw Compressor (Kovacevic, et al., 2007) 
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This Tutorial will provide a step by step guide for the procedure to setup and execute a typical 

twin screw compressor, pump or motor simulation. An example of a dry air compressor with 

3/5 lobe combination, L/D ratio of 1.6 and wrap angle 285 deg has been considered.  

2 SCORGTM Project 

 Launch SCORGTM on the Desktop. 

 Select File → New 

 

 

 Select N35_Template.spt → Open 
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 Save the project in a new folder named TwinScrewSimericsSetup → 

SCORG_Grid_Tutorial.spf 

 

 

 The GUI of SCORGTM in the figure bellow shows the mains items of the front panel. 
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 In Units Tab, Select Length units as ‘m’. This selection has to be the same as the units 

in which input profile coordinates are available. 

 

 Go to Help → Tutorials → Folder opens 

 Copy the compressor rotor profile files → [ 35MaleProfile_P1.dat  and 

35FemaleProfile_P2.dat  ] 

 Copy the compressor suction and discharge port grids → 

[ SCORG_Simerics_Tutorial_Ports_V5.0.sgrd ] 

 Copy the setup template → [ SCORG_Simerics_Tutorial_V5.9.spro ] 

 Paste these files in the working directory → TwinScrewSimericsSetup 
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 Go to User Profile → Browse and Select the Male Rotor Profile from working directory. 

35MaleProfile_P1.dat 

 

 Click ‘Yes’ to overwrite P1.dat. 

 

 Similarly Select the Female Rotor Profile. 

35FemaleProfile_P2.dat 

 

 Click Write To Default. 
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 Click Refresh to view new profiles. 

 

 

 Inspect the Rotor Profile in the GUI for gaps in the tips, starting points of the profile 

indicated by the small yellow circles. Below is the required orientation. 
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 Set Project Units to SI 

 

 

 Set the following Profile Parameters to get desired clearance size: 

GAPI = 0.06mm 

GAPR = 0.06mm 

GAPA = 0.05mm 

*Setting GAPI = 0.06 sets the minimum interlobe clearance as the GAPI. 
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 Go to Geometry → Set the following parameters: 

             

 

 Go to Thermodynamics → Set the following parameters: 

 

 Save the Project. 
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3 SCORGTM Mesh Generation 

SCORGTM is stand-alone numerical CAD-CFD interface used to generate a numerical mesh of 

rotating parts of a screw machine and to transfer it to a general finite volume numerical solver. 

The program generates a block structured hexahedral numerical grid for rotor flow domains, 

solid rotor domains, inlet and outlet ports.  

Inputs Required 

In this step the rotor domain mesh is generated in SCORGTM. The inputs required for this mesh 

generation are: (Kovacevic, et al., 2007). 

 

Control Parameters: 

• Type of the machine. 

• Number of mesh divisions along the lobe in circumferential direction. 

• Number of mesh divisions in radial direction. 

• Number of Angular divisions of the rotation. 

 

Control Switches: 

These Inputs are used to specify the method used for Rotor Profile Input and the required 

mesh calculation options.  

 

 

 Click Grid Module in the project tree 

 In Mesh Type Size set: 

o Circumferential Main = 0 

o Circumferential Gate = 60 

o Radial = 8 

o Angular = 50 

o Interlobe Divisions = 50 

 

 

 

 Distribution Parameters: 

 

These inputs are used for adaptation and distribution of the grid points on the boundaries of 

the domain and for smoothing of rack (Rack is the curve representing a rotor with infinite 

radius which uniquely separates the flow domains of the male and female rotors).  

 

o Type of Distribution → Casing to Rotor Conformal 
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 Meshing Parameters: 

 

Meshing parameters provide control over the distribution of the internal mesh points in each 

cross section of the rotors.  

 

 
 

o both the distribution and meshing parameters can be changed later 

 

 

 

 

 Start Grid Generation through a three step process as below. 

 

 

 

 

 Select Rack Refinement Points = 500 

 

 
 

 Click Numerical Rack Generation 

 

 
 

This operation produces the rack curve between the two profiles. It is required to be executed 

only once in the grid generation process. 
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 Click Boundary Distribution Generation 

 

 
 

 

Information about the progress of the selected activities in the meshing procedure is displayed 

in the output window. Any warning or error and their locations are indicated. If errors occur, it 

is important to manually tune the input parameters which will produce a mesh without errors. 

Graphically the mesh distribution in each section can be visualized and checked for any 

deviation from requirements. The detailed description of methods used for distribution, 

adaptation and generation of numerical mesh is available through the Help in the drop down 

menu. 

 

 

 Inspect report and check that there are no distribution warnings listed 
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 Click Distribution Mesh to visually inspect the distribution in each cross section 
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 In the Distribution Display → Select Quality Criteria = Error Cell 

 

 
 

 Inspect all the distribution positions and ensure that 0 error are reported in each 

position. 

 

 Click Rotor Grid Generation 

 

 
 

 

 

 Inspect report and check that there are no grid errors listed 
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 Click Rotor Grid 2D Mesh to visually inspect the grid in each cross section 
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 Click Quality Critera → Error Cell and Inspect. 

 

 Click Quality Critera → Orthogonality and Inspect. 

 

 

 Inspect the 3D mesh 



SCORGTM V5.9, 2021  

 © PDM Analysis Ltd, 2021 Page | 17  

 

 

 

 
 

 

 In Control Switches → Preprocessor Input File select → Simerics-MP+ 

 Set Vertex Files Start = 1 

 Set Vertex Files End = 50 

 

 
 

 Calculate Preprocessor Files Generation 
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 With this the SCORG Project is complete and the Simerics-MP+ setup can be started.  

 In the directory structure of SCORG Project → Grid → Output consists of Simerics-

MP+ folder. 

 Copy files in this folders to the project working directory → 

TwinScrewSimericsSetup 

 These are Rotor grids and the Simerics Template Setup 
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 The highlighted files are required for full setup. 

 

 

 

4 Simerics MP+ case setup 

 Launch Simerics MP+ 

 Select Open → New → Import port and singlerotor grid 

 

 

 

 Save as [ TwinScrew35_Compressor.spro ] 
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 Click Screw Module → Save As → SCORG_Simerics_Tutorial_V5.9.spro 

 

 

Copy rotor.1, rotor.2 etc files to the working directory.      

 View Geometric Entities by Type: 
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 Add Flow-Turbulence and Heat modules. 
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 Select all volumes and set Ideal Gas Law. 

 

 Select Fluid_rotor and Set Volume Remesh 

 

 Create Interfaces 

 1 – Axial Suction 
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 2- Axial Discharge 
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 3 – Radial Discharge Main Rotor 

 

 4 – Radial Discharge Gate Rotor 
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 Rotor1_rotor has following properties: 

 

 

 Rotor2_rotor has following properties: 

 

 Set Inlet 
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 Set Outlet 

 

 Go to Geometry tree → Select Rotor1_rotor and Rotor2_rotor 

 Go to Results → Select Pressure 

 

 

 Create a monitor point at (0.0, 0.062,0.203) for tracking Pressure history 



SCORGTM V5.9, 2021  

 © PDM Analysis Ltd, 2021 Page | 28  

 

 

 

 While Point01 is active in the selection, Click → Add XY Plot → Select Pressure 

→ Plot 

 

 

 

 Similarly create Plots for Mass Flux through the suction_inlet and discharge_outlet 

boundaries. 
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 Save the project 

 

 

5 Simerics MP+ Solver Calculation 

 Go to Simulation tab → Click Start 
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The time step size is controlled by the number of divisions used for angular discretization 

during grid generation in SCORG. 

 

 Monitor the convergence in residuals: 

 

 
 

 

 Pressure contours on the rotor profile can be seen updated by selecting the boundaries 

in geometric tree. 

 

 

6 Summary 

This document describes the steps to setup a Simerics MP+ model for Screw compressor CFD 

analysis starting from output data generated by SCORGTM Meshing tool. More detailed 

information on using SCORG and Screw compressor mesh generation can be found in user 

guide (SCORG, 2021). The Screw Module built in Simerics MP+ provides a very fast and user 

friendly setup procedure. It is possible to make quick changes in the grids and simply update 

the model by replacing the grid. The setup can be easily duplicated to users own port grids by 
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editing the .spro file in an ordinary text editor. More detailed information on using Simerics 

MP+, Transient simulations and Post-Processing can be found in user guide (Simerics, 2021) 
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