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SCORGTM Setup for CFD Simulation of 

Twin Screw Machines with OpenFOAM 
 

SCORGTM is the CFD grid generation tool for rotary twin screw machines. The tool includes 

additional modules for designing and editing rotor profiles, executing a basic thermodynamic 

calculation based on quasi 1D chamber models and generating the deforming working chamber 

grids for selected commercial CFD solvers. 

For more information on the product please visit the website: www.pdmanalysis.co.uk or refer 

to documentation help. 

This guide lists the steps for setting up a CFD simulation for Roots Blower Compressor with 

SCORGTM and OpenFOAM Solver. The user is expected to be familiar with screw machines, 

CFD and OpenFOAM in order to be able to use these procedures. The setup steps here are 

demonstrated for Windows 10, x64 bit OS. Refer SCORGTM Installation Guide for system and 

hardware requirements. The OpenFOAM pre-processing, solving and post-processing steps are 

demonstrated for Ubuntu 18.04 and 16.04 OS. For more information about running 

OpenFOAM on Windows OS please visit the following websites:  

https://www.openfoam.com/download/install-windows-10.php -- OpenCFD 

https://openfoam.org/download/windows/ -- The OpenFOAM Foundation 
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1 Introduction 

Screw Compressors are rotary positive displacement machines. Although the working principle 

of these machines is simple, the geometry of rotors which are in the form of multi -lobe helical 

screws meshing with each other, is making analysis by use of Computational Fluid Dynamics 

(CFD) challenging. The process starts when the lobes are engaged at one end, which creates 

continuous increase of the volume between the rotors and the casing which reduces pressure in 

the suction domain and draws the working fluid in. Further rotation of the rotors makes this 

volume between the rotors and the casing enclosed when the compression of fluid begins. This 

increases the pressure within the chamber. Further rotation exposes the pressurized fluid to the 

outlet port and the fluid is delivered (Stosic, et al., 2005). Similar process is occurring in other 

helical screw machines such as pumps, vacuum pumps, gear pumps, expanders, extruders and 

motors. The CFD is equally challenging in such machines due to sliding and stretching  

The main objectives of CFD simulations of a screw compressor are to: 

a. Obtain the pressure field inside the rotor chamber and in the suction and discharge 

domains. Example shown in Figure 1-1. 

b. Obtain the velocity fields in critical regions of the computational domain. 

c. Obtain temperature fields in critical regions of the computational domain. 

d. Obtain integral parameters of the machine such as power, mass flow rate, discharge 

temperature, torques on the rotor shafts, etc. 

e. Obtain the loads and temperatures on boundaries with solid parts of the machine for 

further structural and thermal analysis. 

 
Figure 1-1 Pressure Variation diagram of a Twin Screw Compressor (Kovacevic, et al., 2007) 
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This Tutorial will provide a step by step guide for the procedure to setup and execute a typical 

twin screw compressor, pump or motor simulation. An example of a dry air Roots blower with 

2/2 lobe combination has been considered.  

2 SCORGTM Project 

 Launch SCORGTM on the Desktop. 

 Copy RootsGridProject.zip from Tutorials directory and unzip. 

 Select File → Open  

 

 

 Select RootsGrid.spf 
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 Inspect the Rotor Profile in the GUI for gaps in the tips, starting points of the profile 

indicated by the small yellow circles. Below is the required orientation. 

 

 

 Set Project Units to SI 

 

 

 Set the following Profile Parameters to get desired clearance size: 

GAPI = 0.17mm 

GAPR = 0.1mm 

GAPA = 0.15mm 

 Save the Project. 
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3 SCORGTM Mesh Generation 

SCORGTM is stand-alone numerical CAD-CFD interface used to generate a numerical mesh of 

rotating parts of a machine and to transfer it to a general finite volume numerical solver. The 

program generates a block structured hexahedral numerical grid for rotor flow domains, solid 

rotor domains, inlet and outlet ports.  

Inputs Required 

In this step the rotor domain mesh is generated in SCORGTM. The inputs required for this mesh 

generation are: (SCORG, 2021) 

 

Control Parameters: 

• Type of the machine. 

• Number of mesh divisions along the lobe in circumferential direction. 

• Number of mesh divisions in radial direction. 

• Number of Angular divisions of the rotation. 

 

Control Switches: 

These Inputs are used to specify the method used for Rotor Profile Input and the required 

mesh calculation options.  

 

 

 Click Grid Module in the project tree 

 In Mesh Type Size set: 

o Circumferential Main = 0 

o Circumferential Gate = 150 

o Radial = 10 

o Angular = 180 

o Axial Divisions = 25 

o Interlobe Divisions = 60 

 

 
 

 Distribution Parameters: 

 

These inputs are used for adaptation and distribution of the grid points on the boundaries of 

the domain and for smoothing of rack (Rack is the curve representing a rotor with infinite 

radius which uniquely separates the flow domains of the male and female rotors).  

 

o Type of Distribution → Casing to Rotor Conformal (Rane, 2015) 
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 Meshing Parameters: 

 

Meshing parameters provide control over the distribution of the internal mesh points in each 

cross section of the rotors.  

 

 
 

o both the distribution and meshing parameters can be changed later 

 

 

 

 

 Start Grid Generation through a three step process as below. 

 

 Select Rack Refinement Points = 1000 

 

 
 

 Click Numerical Rack Generation 

 

 
 

This operation produces the rack curve between the two profiles. It is required to be executed 

only once in the grid generation process. 
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 Click Boundary Distribution Generation 

 

 
 

 

Information about the progress of the selected activities in the meshing procedure is displayed 

in the output window. Any warning or error and their locations are indicated. If errors occur, it 

is important to manually tune the input parameters which will produce a mesh without errors. 

Graphically the mesh distribution in each section can be visualized and checked for any 

deviation from requirements. The detailed description of methods used for distribution, 

adaptation and generation of numerical mesh is available through the Help in the drop down 

menu. 

 

 

 Inspect report and check that there are no distribution warnings listed 
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 Click Distribution Mesh to visually inspect the distribution in each cross section 
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 In the Distribution Display → Select Quality Criteria = Error Cell 

 

 
 

 Inspect all the distribution positions and ensure that 0 error are reported in each 

position. 

 

 Click Rotor Grid Generation 

 

 
 

 Inspect report and check that there are no grid errors listed 

 

 

 Click Distribution Mesh to visually inspect the grid in each cross section 
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 Click Rotor Grid 2D Mesh to visually inspect the grid in each cross section 

 

 Click Quality Critera → Error Cell and Inspect. 
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 Click Quality Critera → Orthogonality and Inspect. 

 

 

 Inspect the 3D mesh 
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 In Control Switches → Preprocessor Input File select →  OpenFOAM 

 Set Vertex Files Start = 1 

 Set Vertex Files End =   180 [ = Number of Angular Divisions for Casing to Rotor 

type of distribution]   

 
 

 Calculate Preprocessor Files Generation 
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 With this the SCORGTM Project is complete and the OpenFOAM setup can be started.  

 In the directory structure of SCORGTM Project → Grid → Output with consist of 

OpenFOAM and grids folder. 

 The grids folder consists of all time step mesh files named as rotor.1, rotor.2 ,,,etc 

 
 

 The directory SCORGTM Project → Grid → Output→ OpenFOAM contains one sub-

directory for every OpenFOAM version supported. 

 Each of these directories contains two folders: rootsBlowerTutorial is the tutorial 

template directory, while SCORGtoFOAM contains the user libraries to be compiled 

in order to run the case. 
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4 Compile OpenFOAM user libraries [ One time procedure, (Casari & 

Fadiga, 2019) ] 

Ubuntu 16.04 and 18.04 

 Move the outputs of SCORGTM  to the computer in which OpenFOAM is compiled. 

 Open the terminal, source the OpenFOAM environment and move to the 

SCORGToFOAM directory. 

 Move to the SCORGfvMOTION directory 

 

 Exectute the command wmake to compile the user library that handles the SCORG 

dynamic mesh process. 

 

 Move to the SCORGToFoam directory 

 

 Exectute the command wmake to compile the user library that handles the SCORG 

mesh conversion process. 

 

5 OpenFOAM case setup (Casari & Fadiga, 2019) 

 

 Copy the content of the rootsBlowerTutorial folder into the working directory  

 

 Copy the grids folder into the working directory (in case of conformal distribution, 

only the rotor.# files and the roa.1 and rog.1 files are needed) 

 

 Open the file workingDirectory/system/SCORGdict with a text editor 
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 Make sure that the required flag (conformalInterface) is set to true. In order to convert 

different meshes, the user must correctly fill the SCORGdict dictionary.  

 If the user wants to convert also the port meshes, the SCORG output files for the ports 

must be included in the grids directory as well. 

 

 Open the terminal in the case main directory (the working directory), source the 

OpenFOAM environment and run the command “SCORGToFoam” 

 

 Check the mesh in Paraview in order to visualize the result, loading the file case.foam 

contained in the case main directory: 
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 Check the mesh quality running “checkMesh” in the terminal from the case main 

directory. 

 Move to the workingDirectory/suction directory to generate the suction port mesh. 

 The mesh will be generated with the snappyHexMesh utility, starting from the STL 

files into the workingDirectory/suction/constant/triSurface folder. 

 Open the terminal and run “surfaceCheck constant/trisurface/suction.stl”, checking 

if the surface is closed. 

 Run “blockMesh” to generate a background mesh for the snappy procedure. 

 Run “surfaceFeatureExtract” to extract the edges of the surface that must be meshed 

 Check and update the number of processors in the 

workingDirectory/suction/system/decomposeParDict file 

 Run “decomposePar” to prepare for the parallel generation of the mesh (ignore this 

line if a serial run is preferred) 

 Run “snappyHexMesh” for serial mesh generation, or “mpirun -np 4 

snappyHexMesh -parallel” for parallel generation in workingDirectory/suction 

 Run “reconstructParMesh -latestTime -mergeTol 1e-06” to reconstruct the 

generated mesh. 

 Run “rm -r constant/polyMesh”, then “mv 2/polyMesh constant/” and “rm -r 2” to 

move the new mesh in the constant directory. 

 Open the workingDirectory/suction/constant/polyMesh/boundary text file and 

change the suction_inlet type from wall to patch 

 

 Visualize the mesh in paraview and check it with the terminal command 

“checkMesh”. 
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 Move to the workingDirectory/discharge directory to generate the discharge port 

mesh, following the same procedure. 

 In this case, when “surfaceCheck” is run, be sure of checking 

constant/triSurface/discharge.stl file.  

 For the discharge mesh, the discharge_outlet patch in 

workingDirectory/discharge/constant/polyMesh/boundary has to be changed into 

patch type 

 
 Move back to the workingDirectory 

 

 Run “mergeMeshes . discharge/” to merge the main mesh with the discharge port 

mesh 

 

 Run “mergeMeshes . suction/” to merge the main mesh with the discharge port mesh 

 

 Run “cp -r 0.00071839/polyMesh constant” and “rm -r 0.000*” to copy the new 

mesh into the constant folder and remove the time directories created by mergeMeshes 
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 Run “createPatch” to join the ports patches togheter 

 

 Run “cp -r 0.000359*/polyMesh constant” and “rm -r 0.000*” to copy the new mesh 

into the constant folder and remove the time directories created by createPatch. 

 
 Run “topoSet -dict system/topoSetDict.ports” to create faceZones starting from the 

new patches.  

 

 Edit the text file workingDirectory/constant/polyMesh/boundary and change the 

type of the following patches from wall to symmetry: minZMale, maxZMale, 

minZFemale, maxZFemale. 

 

 Run “createBaffles” to create ACMI interfaces. 

 

 N.B. In order to run simulations with the non-conformal distribution the user has to 

create an AMI interface between the two rotors, using the patches interlobeMale and 

interlobeFemale created by the SCORG mesh converter. This feature could introduce 
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some conservation error and it is still under investigation. More information about 

AMI interfaces are available in the createPatchDict.AMI dictionary in the 

workingDirectory/system folder. 

 

 Run “cp -r 0.000359*/polyMesh constant” and “rm -r 0.000*” to copy the new mesh 

into the constant folder and remove the time directories created by createBaffles. 

 
 

 Run “topoSet -dict system/topoSetDict.pZones” to create faceSets  

 Run “decomposePar” for the parallel execution of the numerical calculation. 

 It is possible to change and set thermophysical properties, turbulence properties, 

numerical schemes and time settings from the dictionaries in constant and system 

directories. 

 In order to use exactly the grids generated by SCORG, the deltaT in 

system/controlDict dictionary must be consistent with the angular velocity and the 

number of grids set up in constant/dynamicMeshDict. Otherwise, the software will 

perform a linear interpolation between grids, generating intermediate positions. The 

grid used for every time step is reported in the log file as follow: 

“Blending between 2and2 of 0” indicates that the software is using the grid stored in 

rotor.2 file 

 
“Blending between 2and3 of 0.4563” indicates that the software is interpolating the 

nodal positions between grid 2 and grid 3 
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The interpolation feature must be treated carefully: the interpolation could produce low 

quality mesh elements. 

 

 

 Run “foamJob -p rhoPimpleFoam” to start the simulation. The log file will be 

automatically saved in the working directory. 

 

 Use pyFoamPlotWatcher or foamLog to check the residuals during the simulation. 

pyFoam must be installed by the user, while foamLog is already compiled in 

OpenFOAM standard versions. 

 

https://openfoamwiki.net/index.php/Contrib/PyFoam -- pyFoam  

 

https://www.cfdsupport.com/OpenFOAM-Training-by-CFD-Support/node88.html - 

foamLog 

 

 It is possible to add monitor points in different positions of the rotor and create plots 

for Pressure on these points. The trace of the chamber pressure rise can be seen. 

(To be completed) 

 Different surface reports for the mass flow rate through the In and Out boundaries are 

already set up in the system directory. It is possible to plot the results in the 

workingDirectory/postprocessing folder using gnuplot. 

 

 

https://openfoamwiki.net/index.php/Contrib/PyFoam
https://www.cfdsupport.com/OpenFOAM-Training-by-CFD-Support/node88.html
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 It is possible to create contour plots, glyphs representations and many more post 

processing features in Paraview. 
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6 Summary 

This document describes the steps to setup an OpenFOAM model for Roots Blower CFD 

analysis using grids generated by SCORGTM Meshing tool. More detailed information on using 

SCORG and Screw compressor mesh generation can be found in user guide (SCORG, 2021). 

The set of mesh files generated for a complete cycle are reused cyclically when the simulation 

is run for more than one cycle. Thus, it is possible to continuously run the simulation until 

repeatable results in the monitors and good convergence is obtained. 
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