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SCORGTM Setup for CFD Simulation of 

Twin Screw Machines with ANSYS CFX® 
 

SCORGTM is the CFD grid generation tool for rotary twin screw machines. The tool includes 

additional modules for designing and editing rotor profiles, executing a basic thermodynamic 

calculation based on quasi 1D chamber models and generating the deforming working chamber 

grids for selected commercial CFD solvers. 

For more information on the product please visit the website: www.pdmanalysis.co.uk or refer 

to documentation help. 

This guide lists the steps for setting up a CFD simulation for Twin Screw Compressor with 

SCORGTM and ANSYS CFX Solver. The user is expected to be familiar with screw machines, 

CFD and ANSYS CFX® in order to be able to use these procedures. It is highly recommended 

that books on that topic are studied12 

The setup steps here are demonstrated for Linux & Windows 7, x64 bit OS. Refer SCORGTM 

Installation Guide for system and hardware requirements. 
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1 Introduction 

Screw Compressors are rotary positive displacement machines. Although the working principle 

of these machines is simple, the geometry of rotors which are in the form of multi -lobe helical 

screws meshing with each other, is making analysis by use of Computational Fluid Dynamics 

(CFD) challenging. The process starts when the lobes are engaged at one end, which creates 

continuous increase of the volume between the rotors and the casing which reduces pressure in 

the suction domain and draws the working fluid in. Further rotation of the rotors makes this 

volume between the rotors and the casing enclosed when the compression of fluid begins. This 

increases the pressure within the chamber. Further rotation exposes the pressurized fluid to the 

outlet port and the fluid is delivered (Stosic, et al., 2005). Similar process is occurring in other 

helical screw machines such as pumps, vacuum pumps, gear pumps, expanders, extruders and 

motors. The CFD is equally challenging in such machines due to sliding and stretching  

The main objectives of CFD simulations of a screw compressor are to: 

a. Obtain the pressure field inside the rotor chamber and in the suction and discharge 

domains. Example shown in Figure 1-1. 

b. Obtain the velocity fields in critical regions of the computational domain. 

c. Obtain temperature fields in critical regions of the computational domain. 

d. Obtain integral parameters of the machine such as power, mass flow rate, discharge 

temperature, torques on the rotor shafts, etc. 

e. Obtain the loads and temperatures on boundaries with solid parts of the machine for 

further structural and thermal analysis. 

 
Figure 1-1 Pressure Variation diagram of a Twin Screw Compressor (Kovacevic, et al., 2007) 
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This Tutorial will provide a step by step guide for the procedure to setup and execute a typical 

twin screw compressor, pump or motor simulation. An example of a dry air compressor with 

3/5 lobe combination, L/D ratio of 1.7 and wrap angle 285 deg has been considered.  

2 SCORGTM Project 

 Launch SCORGTM on the Desktop. 

 Select File → New 

 

 

 Select N35_Template.spt → Open 
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 Save the project in a new folder named TwinScrewCFXSetup → 

SCORG_Grid_Tutorial.spf 

 

 

 

 The GUI of SCORGTM in the figure bellow shows the mains items of the front panel. 
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 In Units Tab, Select Length units as ‘m’. This selection has to be the same as the units 

in which input profile coordinates are available. 

 

 Go to Help → Tutorials → Folder opens 

 

 

 

 Copy the compressor rotor profile files → [ 35MaleProfile_P1.dat  and 

35FemaleProfile_P2.dat  ] 

 Copy the compressor suction and discharge port grids → 

[ SCORG_CFX_Tutorial_Ports_V5.4.cfx ] 
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 Copy the CFX setup script → [ SCORG_CFX_Tutorial_V5.9.ccl ] 

 Paste these files in the working directory → TwinScrewCFXSetup 

  

 Go to User Profile → Browse and Select the Male Rotor Profile from working directory. 

35MaleProfile_P1.dat 

 

 Click ‘Yes’ to overwrite P1.dat. 

 

 Similarly Select the Female Rotor Profile. 

35FemaleProfile_P2.dat 

 

 Click Write To Default. 
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 Click Refresh to view new profiles. 
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 Inspect the Rotor Profile in the GUI for gaps in the tips, starting points of the profile 

indicated by the small yellow circles. Below is the required orientation.

 

 

 Set Project Units to SI 

 

 

 Set the following Profile Parameters to get desired clearance size: 

GAPI = 0.06mm 

GAPR = 0.06mm 

GAPA = 0.05mm 

*Setting GAPI = 0.06 sets the minimum interlobe clearance as the GAPI. 
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 Go to Geometry → Set the following parameters: 

        

        

 Go to Thermodynamics → Set the following parameters: 

 

 Save the Project. 
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3 SCORGTM Mesh Generation 

SCORGTM is stand-alone numerical CAD-CFD interface used to generate a numerical mesh of 

rotating parts of a screw machine and to transfer it to a general finite volume numerical solver. 

The program generates a block structured hexahedral numerical grid for rotor flow domains, 

solid rotor domains, inlet and outlet ports.  

Inputs Required 

In this step the rotor domain mesh is generated in SCORGTM. The inputs required for this mesh 

generation are: (Kovacevic, et al., 2007). 

 

Control Parameters: 

• Type of the machine. 

• Number of mesh divisions along the lobe in circumferential direction. 

• Number of mesh divisions in radial direction. 

• Number of Angular divisions of the rotation. 

 

Control Switches: 

These Inputs are used to specify the method used for Rotor Profile Input and the required 

mesh calculation options.  

 

 

 Click Grid Module in the project tree 

 In Mesh Type Size set: 

o Circumferential Main = 0 

o Circumferential Gate = 60 

o Radial = 8 

o Angular = 50 

o Interlobe Divisions = 50 

 

 

 

 Distribution Parameters: 

 

These inputs are used for adaptation and distribution of the grid points on the boundaries of 

the domain and for smoothing of rack (Rack is the curve representing a rotor with infinite 

radius which uniquely separates the flow domains of the male and female rotors).  

 

o Type of Distribution → Casing to Rotor Conformal 
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 Meshing Parameters: 

 

Meshing parameters provide control over the distribution of the internal mesh points in each 

cross section of the rotors.  

 

 
 

o both the distribution and meshing parameters can be changed later 

 

 

 

 

 Start Grid Generation through a three step process as below. 

 

 

 

 

 Select Rack Refinement Points = 400 

 

 
 

 Click Numerical Rack Generation 

 

 
 

This operation produces the rack curve between the two profiles. It is required to be executed 

only once in the grid generation process. 
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 Click Boundary Distribution Generation 

 

 
 

 

Information about the progress of the selected activities in the meshing procedure is displayed 

in the output window. Any warning or error and their locations are indicated. If errors occur, it 

is important to manually tune the input parameters which will produce a mesh without errors. 

Graphically the mesh distribution in each section can be visualized and checked for any 

deviation from requirements. The detailed description of methods used for distribution, 

adaptation and generation of numerical mesh is available through the Help in the drop down 

menu. 
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 Inspect report and check that there are no distribution warnings listed 

 
 

 

 Click Distribution Mesh to visually inspect the distribution in each cross section 
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 In the Distribution Display → Select Quality Criteria = Error Cell 

 

 
 

 Inspect all the distribution positions and ensure that 0 error are reported in each 

position. 

 

 Click Rotor Grid Generation 

 

 
 

 

 

 Inspect report and check that there are no grid errors listed 
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 Click Rotor Grid 2D Mesh to visually inspect the grid in each cross section 
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 Click Quality Critera → Error Cell and Inspect. 

 

 Click Quality Critera → Orthogonality and Inspect.

 

 

 Inspect the 3D mesh 
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 In Control Switches → Preprocessor Input File select → ANSYS CFX 

 Set Vertex Files Start = 1 

 Set Vertex Files End = 50         [ = Number of Angular Divisions  ]   

      

 

 
 

 Calculate Preprocessor Files Generation 
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 With this the SCORGTM Project is complete and the CFX setup can be started.  

 In the directory structure of SCORGTM Project → Grid → Output with consist of CFX 

and grids folder. 

 Copy these two folders in the project working directory → TwinScrewCFXSetup 

 The CFX folder consists of two sub folders 

o CFXPreSetup 

o JunctionBox 
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 JunctionBox folder consists of the Fortran codes that need to be compiled to generate 

an external library that will be linked to the CFX solver during executions in order to 

be able to read the set of grids generated by SCORGTM 

 
 

 

4 Compiler Environment setup [ One time procedure ] 

Intel Fortran Compiler is required in the initial stages of the case setup. It is not required to 

repeat this step for every CFX case setup. 

For Windows OS, 

• Install Microsoft Visual Studio 2008 or any later version. 
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• Install Intel Parallel Studio XE 2011 for the Fortran compiler. 

 

Below are some links that provide these installers (Evaluation Editions), but if you have other 

Fortran compiler then it can be used. 

 

http://www.microsoft.com/en-gb/download/details.aspx?id=40787 

 

https://software.intel.com/en-us/intel-parallel-studio-xe/ 

 

You can then access the Intel Fortran compiler command prompt as shown below. Try to run 

ifort command to check if it is recognized and properly works. 

 

For Linux, check if either of F77, F90, G77, G90 or a Portland compiler is installed. 

4.1 Compilation of Junction box Subroutines 

Junction box subroutines are used by CFX solver to read the new mesh coordinates of the rotor 

domain every time step. The source code and compilation command used for this purpose is 

available in the [ \\TwinScrewCFXSetup\CFX\JunctionBox ] folder. 

For Windows, 

In order to create the library and link the object files compiled by Fortran compiler we will use 

the cfx command ‘cfx5mkext’. For this you need to first set the environment variable ‘Path’ 

and point to the CFX installation directory.  

System Properties → Advanced → Environment Variables → System Variables → Path. 

Add the path of [..AnsysInc\v130\CFX\bin] to the variable separated by a semicolon from 

others. 

http://www.microsoft.com/en-gb/download/details.aspx?id=40787
https://software.intel.com/en-us/intel-parallel-studio-xe/
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Once the path is set, launch Intel Fortran Compiler command prompt. Change the working 

directory. Issue the command mentioned in Compile.txt file. 

 

-double is a flag for double precision CFX simulation. You need to remove it for Single 

precision simulations. 

 

-name is a flag for the routine object and is called by the solver. 
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 Copy the created library “winnt-amd64” in the C:\windows folder for easy access and 

subsequent reuse 
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For Linux, 

Go to the working directory using Linux command prompt and issue the following commands. 

 Use Intel Fortran Compiler 2015 

 The procedure for compilation is same as for windows. 

 A folder linux-amd64 will be created when this step is successful.  

It is not required to repeat this step for every CFX case setup and the folder winnt-

amd64/linux-amd64 can be just copied and used again in another case. But this library is 

specific to a given operating system and a given architecture. So in case you are running on a 

32 bit OS or any other OS (Win 8 ) etc. you need to execute this step and provide the library 

so created to the CFX solver definition file. The library is common for Serial and Parallel 

Simulations. 
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5 CFX Pre case setup 

 Launch CFX from [ \\TwinScrewCFXSetup\CFX\CFXPreSetup ] folder 

 

 
 

 Select New → General 

 
 

 

 Go to → Session → Play Session  → Select  SingleRotorDomainImport.pre 
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 This imports the rotor grid in starting position and single domain rotor is created in 

the setup. 

 Save case as Rotor.cfx 

 
 

 

 

 Right click Mesh → Import Mesh → CFX Mesh  → Select 

SCORG_CFX_Tutorial_Ports_V5.4.cfx 
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 Go to File → Import → CCL → Select SCORG_CFX_Tutorial_V5.9.ccl 

 
 

 

 

 Save case as Testrun1.cfx 
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 In the setup there are three non-conformal grid interfaces 

o Domain Interface 1 

o Domain Interface 2 

o Domain Interface 3 

 

 Interface 1 is between the Suction Port and the two rotors. 

o Inspect the interface settings. 

o Right click Domain Interface 1 → Mesh Statistics → min / max z should 

match so that there is no gap between the faces. 
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 Interface 2 is between the Discharge Port and the two rotors. 

o Inspect the interface settings. 

o Right click Domain Interface 2 → Mesh Statistics → Min / Max Z should 

match so that there is no gap between the faces. 
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 Interface 3 is between the two rotors and also with the Discharge Port and a special 

zone selection is required in such type of domain connection. 

o Inspect the interface settings.  

o Notice that the face zones form a cross exchange of boundaries as highlighted. 

 
 

 Go to User → Edit in Command Editor → Set the correct MeshDir, NMeshes and rog 

Centre. 
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 Go to Expressions → Set the correct parameters 

o nelperlobe = Number of divisions in Angular = 50 

o nlobe = Number of Lobes on Male Rotor = 3 

o revpermin = rpm of Male rotor = 8000 

 
 

 

 Go to Mesh Read → Set correct Library Path → Start of time Step 

o Library Path is the folder where winnt-amd64 has been placed 
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 Move TestRun1.cfx and grids folder → TwinScrewCFXSetup → Open TestRun1.cfx 

o Only rotor.1, rotor.2 etc file from grids folder will be used, other files can be 

deleted. 

 

6 CFX Solver Calculation 

 Click Define Run → Save Definition file as TestRun1.def 

 
 

 

 

 Select → Double Precision → HP MPI Local Parallel → Start Run 
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 In the Time stepping Information, mesh map generation and replacement with 

consecutive meshes should be reported 
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6.1 Restarting a Simulation from an intermediate Stop 

You can stop the simulation at an intermediate step by hitting the stop button in CFXSolver 

GUI or through command line. This will complete the current coefficient loop iteration and 

close the solver. Results file is written for the current completed time step. 

To restart from the same flow time specify this result file as the initialization file and check on 

the continue history from initial file. This will continue the residual monitors from the same 

time steps and also the junction box routine will call the corresponding mesh file from the grids 

directory. 
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7 Distribution Options 

There are three options available in the Type of Distribution (Rane, 2015) 

a. Rotor to Casing  

Generates a smooth rotor surface and node distribution on the rotor can be controlled 

using Distribution Adaptation factors. This gives good quality rotor profile in 3D. 

b. Casing to Rotor Nonconformal 

Generates an orthogonal cell structure with possibility to independently refine the 

interlobe leakage region. This gives better leakage predictions. 

c. Casing to Rotor Conformal 

Generates an orthogonal cell structure with a single domain containing both the rotors. 

 

The selection of the type of distribution is dependent on the type of screw machine being solved 

and the CFD solver in consideration. For ANSYS CFX all the three options are available. 

The preferred option is Casing to Rotor Conformal as this will generate a single block 

structured grid that has both the rotors and eliminates the interface between them 

Refer to SCORG Help Manual for more details. 

8 Summary 

This document describes the steps to setup an ANSYS CFX model for Screw compressor CFD 

analysis starting from output data generated by SCORGTM Meshing tool. More detailed 

information on using SCORG and Screw compressor mesh generation can be found in user 

guide (SCORG, 2021). As mentioned earlier the compilation of junction box routines is a 

onetime process but has to be done whenever the operating system or its architecture changes. 

The set of mesh files generated for a complete cycle are reused cyclically when the simulation 

is run for more than one cycle. Thus it is possible to continuously run the simulation until 

repeatable results in the monitors and good convergence is obtained. It is also possible to stop 

and restart the simulation in between, change certain Boundary conditions, Solver control 

parameters or save the intermediate results. More details information on using ANSYS CFX, 

Transient simulations and Post-Processing can be found in user guide (ANSYS CFX, 2021). 
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